Jump to content

Audio Channel Mapping


Recommended Posts

Yesterday I was creating the final file for film I had previously graded. I needed to render my existing graded output with both a stereo and a surround track that was finished in ProTools.

I thought I would get a feel for Mistika in terms of finishing software. I successfully imported all the materials and went to the audio router panel and mapped all the channels. But from playing with it and reading the manual it doesn't appear that Mistika has the necessary infrastructure to understand track types and the meta data for individual channels inside tracks. I can map all 8 channels, but not separate them into two tracks and append the channel order in each track.

I saw that the DCP module can handle all this, but not the regular output module. I also saw some notes about the avconfig file where you can manually setup ffmpeg parameters, though that would be quite hands-on.

I have other software I can do this with instead. But when I read that Mistika is good as finishing software I thought it would be able to handle this too.

How do folks use it create their final deliverables?

Link to comment
Share on other sites

Hi there Jan 

We do map the Chanel’s separately

you need to put them one on top of the other. And arrange them like


were L is the top most.

If you need you can split stereo to 2 mono by brake audio in the edit tab  

and then in the audio router

1/2 change left and right. 

3/4 also left and right

5/6 left and right

Now when you export it will be the correct surround layout.

Hope it help

cheers Yoav 

Link to comment
Share on other sites

7 hours ago, Yoav Raz said:

Now when you export it will be the correct surround layout.

Right, that's what I did. Make sense if you need a single track.

In my case I mapped the surround files (6 mono files) to channel 1-6 in L,R,C,LFE,Ls,Rs order. Then mapped the stereo file to channels 7 and 8.

But when I render that, I get 1x 8 channel stream instead of 1x 6 channel stream and 1x 2 channel stream.

Link to comment
Share on other sites

Hi Jan,

Unfortunately, Mistika cannot understand that there are two groups of audio tracks (surround file and stereo file). You have to manage that manually by hiding the tracks that you don't want to include in your deliverable, so you have to do two versions, one with the surround tracks and another one with the stereo tracks.  


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.