Jump to content

Checksum + Copy + Verification

Recommended Posts

I'm having trouble with quite a simple workflow.


The idea is to generate a checksum for a given file or folder, copy it to a new location and verify the copy.

Here is a screenshot:



If I run the workflow it fails, but the files are copied properly.

If I run a verification of the copied files on a separate workflow there is no error.


Workflows build 20200504, Windows 10


Link to comment
Share on other sites

Hi Davd,

in the first checksum (the one that generates it) you need to disable the "Validate Input" Property


the logic is:

if that property is ON, the checksum files are expected to exist, and are compared with the file (the file is validated)

if the property is OFF the checksum files are generated (if they exist, they are overwritten)

so in your workflow, the first checksum needs to have" Validate Input"=Disabled and the second one needs to have "Validate Input"=Enabled


I hope this helps,


kindly yours


Link to comment
Share on other sites

That's the node setup I'm using.

It actually creates the md5 at source, copies the files but then fails.

The copy is correct, but there's something that makes the workflow throw an error



There's enough disk space, permissions shouldn't be an issue as the files are actually written to the destination.


Edited by dglozano@gmail.com
fix snapshot
Link to comment
Share on other sites

Hi David,

We are trying to reproduce the problem, but unfortunately it is not happening in our systems. We just fixed a bug with the Move node than confused us a bit,  but it is not in  the Copy node and we can't reproduce it.

If not yet, please could you try the same Workflow having both  folders in the system disk? (just to discard that  it is not related  with potential filesystem or network refresh latencies  )

Any other detail you could think  to reproduce the problem?   



Link to comment
Share on other sites

Hi Javier,


I have now tried in two different computers, both fail. Tried different folders, from and to different locations.

I was successful when copying smaller folders, but it has also failed on a single file. It's very random. Not sure how can I help you to find the issue.

The folder that always fails is 100Gb, 24 Subfolders, 280 Files. I tried a simple copy of this folder, with no checksums, and it also fails.

I just tried with another folder. 29Gb, 19 Subfolders, 238 Files. Failed on both my desktop and laptop computers.




Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.